Two different functions in different files do the same thing - fill a partial page with zeroes. Add that functionality to vm_page.c and remove it elsewhere to avoid code duplication.
Details
Details
Diff Detail
Diff Detail
- Repository
- rG FreeBSD src repository
- Lint
Lint Skipped - Unit
Tests Skipped
Event Timeline
sys/vm/vm_page.c | ||
---|---|---|
5090 | I'd suggest noting that this function may temporarily drop the object lock. | |
5093 | This name is somewhat strange. From the VM's perspective it's not invalidating the page (which normally would involve clearing bits from the page's valid mask), it's just zeroing a region of it. It's the tmpfs and shm objects that are being invalidated. I'd suggest vm_page_grab_zero_partial() or something like that. | |
5130 | I believe most of this function could be replaced by vm_page_grab_valid(&m, object, pindex, VM_PAGE_ALLOC_WAITOK); |