Page MenuHomeFreeBSD

rtld/tests: Avoid function name conflict with libc opendir()
ClosedPublic

Authored by arichardson on Jul 5 2021, 8:40 AM.
Tags
None
Referenced Files
Unknown Object (File)
Sun, Mar 16, 10:27 PM
Unknown Object (File)
Feb 24 2025, 9:57 AM
Unknown Object (File)
Feb 23 2025, 7:14 PM
Unknown Object (File)
Feb 20 2025, 2:09 PM
Unknown Object (File)
Feb 13 2025, 9:05 PM
Unknown Object (File)
Feb 12 2025, 9:44 PM
Unknown Object (File)
Jan 29 2025, 3:05 AM
Unknown Object (File)
Jan 29 2025, 2:54 AM
Subscribers

Details

Summary

This prevents these tests from being compiled with ASAN since the asan
interceptors also define opendir() but matching the libc function.

Diff Detail

Repository
rG FreeBSD src repository
Lint
Lint Not Applicable
Unit
Tests Not Applicable

Event Timeline

This revision is now accepted and ready to land.Jul 5 2021, 8:59 AM

We have fdopendir in libc I wonder if this won't be confusing. Maybe we should rename this to something like rtld_opendir.
But whatever name your choose this LGTM.