Remove the vm_page_(un)hold() KPIs. Some KPIs still have "hold" in the
name, e.g., pmap_extract_and_hold(). I'm not sure how best to handle
these. I think "hold" is a better name than "wire" for a general
reference counter, so I'm not really happy renaming them to
s/hold/wire/.
In some places, after unholding we now have to check whether the page has
been removed from its object, in which case we free the page if its
wire_count has dropped to 0. In a future change I would prefer to move
this logic into vm_page_unwire_noq() to avoid memory leaks caused by
missing m->object == NULL checks.