config_intrhook doesn't need to be a two-pointer TAILQ. We rarely add/delete
from this and so those need not be optimized. Instaed, use the one-pointer
STAILQ plus a uintptr_t to be used as a flags word. This will allow these
changes to be MFC'd to 12 and 13 to fix a race in removable devices.
Details
Details
- Reviewers
mav - Commits
- rG88a55912032a: config_intrhook: Move from TAILQ to STAILQ and padding
Diff Detail
Diff Detail
- Repository
- rS FreeBSD src repository - subversion
- Lint
Lint Passed - Unit
No Test Coverage - Build Status
Buildable 37674 Build 34563: arc lint + arc unit
Event Timeline
sys/sys/kernel.h | ||
---|---|---|
471 | Maybe call it ich_pad in this commit since you end up renaming it in D29005 anyway. I guess then you might say "and keep padding" or some such instead in your commit log instead of "and add flags" and similarly adjust the log to say you are leaving the second pointer as a padding placeholder for a subsequent commit. |
Comment Actions
I'd prefer keeping them separate. I'd like people to have a bisection point that's just the STAILQ in case there's a bug with it...