Page Menu
Home
FreeBSD
Search
Configure Global Search
Log In
Files
F107915950
D32172.diff
No One
Temporary
Actions
View File
Edit File
Delete File
View Transforms
Subscribe
Mute Notifications
Flag For Later
Award Token
Size
2 KB
Referenced Files
None
Subscribers
None
D32172.diff
View Options
diff --git a/stand/forth/menu-commands.4th b/stand/forth/menu-commands.4th
--- a/stand/forth/menu-commands.4th
+++ b/stand/forth/menu-commands.4th
@@ -128,6 +128,7 @@
s" set hw.ata.atapi_dma=0" evaluate
s" set kern.eventtimer.periodic=1" evaluate
s" set kern.geom.part.check_integrity=0" evaluate
+ s" set boot_safe=YES" evaluate
;
: safemode_disable ( -- )
@@ -136,6 +137,7 @@
s" hw.ata.atapi_dma" unsetenv
s" kern.eventtimer.periodic" unsetenv
s" kern.geom.part.check_integrity" unsetenv
+ s" boot_safe" unsetenv
;
: init_safemode ( N -- N )
diff --git a/stand/lua/core.lua b/stand/lua/core.lua
--- a/stand/lua/core.lua
+++ b/stand/lua/core.lua
@@ -179,12 +179,14 @@
loader.setenv("hw.ata.atapi_dma", "0")
loader.setenv("kern.eventtimer.periodic", "1")
loader.setenv("kern.geom.part.check_integrity", "0")
+ loader.setenv("boot_safe", "YES")
else
loader.unsetenv("kern.smp.disabled")
loader.unsetenv("hw.ata.ata_dma")
loader.unsetenv("hw.ata.atapi_dma")
loader.unsetenv("kern.eventtimer.periodic")
loader.unsetenv("kern.geom.part.check_integrity")
+ loader.unsetenv("boot_safe")
end
core.sm = safe_mode
end
diff --git a/stand/man/loader_simp.8 b/stand/man/loader_simp.8
--- a/stand/man/loader_simp.8
+++ b/stand/man/loader_simp.8
@@ -22,7 +22,7 @@
.\" OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
.\" SUCH DAMAGE.
.\"
-.Dd September 29, 2021
+.Dd September 30, 2021
.Dt LOADER_SIMP 8
.Os
.Sh NAME
@@ -339,6 +339,21 @@
utility.
.It Va boot_pause
During the device probe, pause after each line is printed.
+.It Va boot_safe
+Force userland to boot in
+.Dq safe mode ,
+which may disable or limit the functionality of some services that may not be
+desired in safe mode.
+This is typically set by selecting
+.Dq safe mode
+in the loader menu, which also sets some other hints for the kernel.
+Applications wishing to respect safe mode should
+.Sy only
+test for the presence of
+.Va boot_safe
+in
+.Xr kenv 1 ,
+not for any particular value.
.It Va boot_serial
Force the use of a serial console even when an internal console
is present.
File Metadata
Details
Attached
Mime Type
text/plain
Expires
Mon, Jan 20, 9:16 AM (20 h, 46 m)
Storage Engine
blob
Storage Format
Raw Data
Storage Handle
15976393
Default Alt Text
D32172.diff (2 KB)
Attached To
Mode
D32172: loader: set boot_safe=YES when safe mode is selected
Attached
Detach File
Event Timeline
Log In to Comment