This seems a bit preferable to open-coding it. No functional change
intended.
Details
Details
Diff Detail
Diff Detail
- Repository
- rG FreeBSD src repository
- Lint
Lint Not Applicable - Unit
Tests Not Applicable
Event Timeline
Comment Actions
I personally would prefer something without underscore prefix. The latter usually means something internal and not supposed to be used. But both macro working on ID and macro working on state definitely have the same level of visibility and usage - are supposed to be used only in pf(4) internally.
I can suggest two options:
PF_IDHASHID(id) PF_IDHASH(state)
or
PF_IDHASH(id) PF_STHASH(state)
More options are also possible.